Fail to install zyGrib on Ubuntu

Image Ici on parle français ou anglais, comme on veut, comme on peut.
Image Here we speak french or english, as we want, as we can.

Moderator: jza

Forum rules
Image Ici on parle français ou anglais, comme on veut, comme on peut, mais on n'oublie jamais que l'on discute entre humains.
Il ne faut surtout pas oublier les mots magiques: bonjour, salut, merci, etc.
Les messages impolis sont rejetés et restent sans réponse.
Il faut souvent être patient, car il y a plein d'autres activités encore plus passionantes dans notre vie.

Image Here we speak french or english, as we want, as we can, but we never forget that we discuss between humans.
Do not forget the magic words: hello, hi, thank you, etc.
Rude messages are rejected and remain unanswered.
It is often necessary to be patient because there are many other activities even more exciting in our life.
Post Reply
pycke
Posts: 1
Joined: 02 Aug 2011 13:58

Fail to install zyGrib on Ubuntu

Post by pycke » 02 Aug 2011 14:05

Hi,

I tried to install zyGrib under Ubuntu, but fail to get the program up and running.

I downloaded the files, unpacked them and then started a terminal session in the directory in which the files were unpacked.

I then entered the command "make", but got the following error

/usr/bin/ld: cannot find -lqwt-qt4
collect2: ld returned 1 exit status
make[1]: *** [zyGrib] Error 1
make[1]: Leaving directory `/home/pycke/Downloads/zyGrib-5.0.2/src'
make: *** [zyGrib] Error 2

I then tried to follow the instruction specific to Ubuntu natty and entered the following command

deb http://doc.hausser.ch/debpackages ubuntu-dha natty

No command 'deb' found, did you mean:
Command 'debc' from package 'devscripts' (main)
Command 'derb' from package 'libicu-dev' (main)
Command 'dab' from package 'bsdgames' (universe)
Command 'debi' from package 'devscripts' (main)
Command 'xdeb' from package 'xdeb' (universe)
deb: command not found

I m new to Linux. Can someone please guide me and help how to get zyGrid up and running on my Linux Ubuntu PC ?

Many thanks,

Bart Pycke

DomH
Site Admin
Posts: 303
Joined: 23 Jan 2009 09:03

Re: Fail to install zyGrib on Ubuntu

Post by DomH » 03 Aug 2011 20:15

pycke wrote:Hi,

I tried to install zyGrib under Ubuntu, but fail to get the program up and running.

I downloaded the files, unpacked them and then started a terminal session in the directory in which the files were unpacked.

I then entered the command "make", but got the following error

/usr/bin/ld: cannot find -lqwt-qt4
collect2: ld returned 1 exit status
make[1]: *** [zyGrib] Error 1
make[1]: Leaving directory `/home/pycke/Downloads/zyGrib-5.0.2/src'
make: *** [zyGrib] Error 2

I then tried to follow the instruction specific to Ubuntu natty and entered the following command

deb http://doc.hausser.ch/debpackages ubuntu-dha natty

No command 'deb' found, did you mean:
Command 'debc' from package 'devscripts' (main)
Command 'derb' from package 'libicu-dev' (main)
Command 'dab' from package 'bsdgames' (universe)
Command 'debi' from package 'devscripts' (main)
Command 'xdeb' from package 'xdeb' (universe)
deb: command not found

I m new to Linux. Can someone please guide me and help how to get zyGrid up and running on my Linux Ubuntu PC ?

Many thanks,

Bart Pycke
Hello,
Just look carefully the download page, packages for debian/ubuntu already exist
Bonne journée ou bonne soirée (vous pouvez choisir)
Have a nice day or good night (you can choose)
Guten Morgen oder gute Nacht (Sie können wählen)

DomH

chrisnofneur
Posts: 1
Joined: 21 Aug 2011 19:38

Re: Fail to install zyGrib on Ubuntu

Post by chrisnofneur » 21 Aug 2011 19:40

The following will do the trick :

Code: Select all

wget http://doc.hausser.ch/debpackages/dha-debpackages.key -O - | sudo apt-key add -
sudo apt-get install zygrib

air-guitar-hero
Posts: 1
Joined: 05 Oct 2011 23:53

Re: Fail to install zyGrib on Ubuntu

Post by air-guitar-hero » 06 Oct 2011 17:49

Hi pycke,

If you're new to linux you should use prebuilt packages (easiest / fastest) but if you feel like jumping in and want to compile from src, this patch worked for me (not sure if this will work for you):

Code: Select all

diff -ru zyGrib-5.0.6-orig//src/zyGrib.pro zyGrib-5.0.6/src/zyGrib.pro
--- zyGrib-5.0.6-orig//src/zyGrib.pro   2011-09-10 08:59:30.000000000 +0200
+++ zyGrib-5.0.6/src/zyGrib.pro 2011-10-05 18:12:50.800772195 +0200
@@ -28,8 +28,8 @@
        ICON = ../img/zyGrib.icns
 }
 else {
-       INCLUDEPATH += /usr/include/qwt-qt4/
-       LIBS += -lqwt-qt4
+       INCLUDEPATH += /usr/include/qwt/
+       LIBS += -lqwt
        DESTDIR = .
 }
 }
Apparently I can not add the patch as a file to my reply, so here's what you do:
  • 1. Copy and paste the code above in your favourite text editor, save it as zyGrib-5.0.6-qwt-qt4.patch in the zyGrib-5.0.6 directory (the one you unpacked from zyGrib-5.0.6.tgz).
    2. cd to the zyGrib-5.0.6 directory in your terminal session.
    3. Type: patch -p1 <zyGrib-5.0.6-qwt-qt4.patch Before running make!
    4. Output from this command should read: patching file src/zyGrib.pro

Regards, and keep learning linux!

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 2 guests