Problem de compile Version 3.8.3

Image Ici on parle français ou anglais, comme on veut, comme on peut.
Image Here we speak french or english, as we want, as we can.

Moderator: jza

Forum rules
Image Ici on parle français ou anglais, comme on veut, comme on peut, mais on n'oublie jamais que l'on discute entre humains.
Il ne faut surtout pas oublier les mots magiques: bonjour, salut, merci, etc.
Les messages impolis sont rejetés et restent sans réponse.
Il faut souvent être patient, car il y a plein d'autres activités encore plus passionantes dans notre vie.

Image Here we speak french or english, as we want, as we can, but we never forget that we discuss between humans.
Do not forget the magic words: hello, hi, thank you, etc.
Rude messages are rejected and remain unanswered.
It is often necessary to be patient because there are many other activities even more exciting in our life.
Post Reply
pterozaurus
Posts: 2
Joined: 07 Feb 2010 13:19

Problem de compile Version 3.8.3

Post by pterozaurus » 07 Feb 2010 14:12

Bonjour, je trouve le travail que vous faites superbe!!
Mon problème est que je arrive pas de compile zyGrib. Il y as ce erreur:
make[1]: Entering directory `/home/sdann/zygrib/zyGrib-3.8.3/src'
g++ -c -pipe -O2 -D_REENTRANT -Wall -W -DQT_NO_DEBUG -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtXml -I/usr/include/qt4 -Iutil -Imap -IGUI -Ibzip2 -Izlib-1.2.3 -Iproj-4.6.0/src -Iobjs -IGUI -o objs/DialogFonts.o DialogFonts.cpp
In file included from DialogFonts.cpp:26:
DialogFonts.h:65: error: field ‘hashFontSelectors’ has incomplete type
DialogFonts.cpp: In member function ‘QFont DialogFonts::getFontItem(FontCode)’:
DialogFonts.cpp:130: error: ‘hashFontSelectors’ was not declared in this scope
DialogFonts.cpp: In member function ‘QFrame* DialogFonts::createFrameGui(QWidget*)’:
DialogFonts.cpp:150: error: ‘hashFontSelectors’ was not declared in this scope
make[1]: *** [objs/DialogFonts.o] Fehler 1
make[1]: Leaving directory `/home/sdann/zygrib/zyGrib-3.8.3/src'
make: *** [zyGrib] Fehler 2
qu-es-que il-me manque? J'ai Debian Lenny avec qt4.
Pour installer avec apt-get/aptitude j'ai ajouter http://doc.hausser.ch/....... et la cle GPG, mais il y as que la Version 3.6.3_ubuntu1 et pas la version actuel.

Merci pour votre aide.

Stephan

DomH
Site Admin
Posts: 303
Joined: 23 Jan 2009 09:03

Re: Problem de compile Version 3.8.3

Post by DomH » 07 Feb 2010 14:25

pterozaurus wrote:Bonjour, je trouve le travail que vous faites superbe!!
qu-es-que il-me manque? J'ai Debian Lenny avec qt4.
Pour installer avec apt-get/aptitude j'ai ajouter http://doc.hausser.ch/....... et la cle GPG, mais il y as que la Version 3.6.3_ubuntu1 et pas la version actuel.

Stephan
bonjour,

En effet, je n'ai pas encore fait les paquets pour les versions "anciennes" qui n'ont pas encore qt4.5 dans le dépôt free, parce que je n'ai pas encore terminer de monter des machines virtuelles avec les anciennes versions de ubuntu <=8.10 et je n'ai plus de machines qui tournent sous ces versions. Je dois encore les compléter avec des environnements de compilation qui ne plante pas...

Et ensuite je pourrai vous dire ce qui manque ou si on se trouve à la frontière du passage de la qt4.4 à la qt4.5 qui nécessite d'installer cette version sur ubuntu 8.10 ou lenny pour pouvoir compiler. Et comme elle n'est pas dans les dépôts c'est un peu le souk...
Bonne journée ou bonne soirée (vous pouvez choisir)
Have a nice day or good night (you can choose)
Guten Morgen oder gute Nacht (Sie können wählen)

DomH

jza
Site Admin
Posts: 600
Joined: 19 Jan 2009 00:22

Re: Problem de compile Version 3.8.3

Post by jza » 07 Feb 2010 18:13

pterozaurus wrote: qu-es-que il-me manque? J'ai Debian Lenny avec qt4.
Bonjour
Il y a en effet un souci avec la version de Qt.
Cette fois la solution est simple : pour que la version 3.8.3 de zyGrib se compile avec Débian Lenny, il faut ajouter 1 ligne au fichier src/util/Util.h

Code: Select all

#include <QHash>
avec les autres include, à la ligne 33 par exemple.

Il n'y a aucune garantie que les prochaines versions de zyGrib soient utilisables avec Qt inférieur à 4.5... et un jour il utilisera même QT4.6

Mode troll:
Le problème est que Debian installe toujours des versions dépassées des outils (ils disent "éprouvées", mais dans les faits c'est pareil), mais que ses utilisateurs veulent des versions récentes des logiciels... et on les comprend... mais dans ce cas pourquoi persévèrent-ils à utiliser Debian ???
A+
Jacques

pterozaurus
Posts: 2
Joined: 07 Feb 2010 13:19

Re: Problem de compile Version 3.8.3

Post by pterozaurus » 10 Feb 2010 23:06

Merci jza,
j'ai ajouter la ligne et ca fonctionne parfaitement!

Stephan

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests