probleme pour installer zygrib sur ubuntu 9.10

Image Ici on parle français ou anglais, comme on veut, comme on peut.
Image Here we speak french or english, as we want, as we can.

Moderator: jza

Forum rules
Image Ici on parle français ou anglais, comme on veut, comme on peut, mais on n'oublie jamais que l'on discute entre humains.
Il ne faut surtout pas oublier les mots magiques: bonjour, salut, merci, etc.
Les messages impolis sont rejetés et restent sans réponse.
Il faut souvent être patient, car il y a plein d'autres activités encore plus passionantes dans notre vie.

Image Here we speak french or english, as we want, as we can, but we never forget that we discuss between humans.
Do not forget the magic words: hello, hi, thank you, etc.
Rude messages are rejected and remain unanswered.
It is often necessary to be patient because there are many other activities even more exciting in our life.
Post Reply
yabiti
Posts: 2
Joined: 21 Feb 2010 16:14

probleme pour installer zygrib sur ubuntu 9.10

Post by yabiti » 21 Feb 2010 16:25

bonjour
je debute sur linux et j'avoue que je ne comprend pas mon probleme

j'ai voulu installer zygrib 3.8.3
j'ai decompressé puis lancé la commende make.

mais a chaque fois ça plante

avec :
QTBIN=/usr/bin
j'ai le probleme suivant a la fin :
make[1]: quittant le répertoire « /home/yaour/Téléchargements/zyGrib-3.8.3/src/proj-4.6.0/src »
cd src; /usr/bin/qmake; make
make[1]: entrant dans le répertoire « /home/yaour/Téléchargements/zyGrib-3.8.3/src »
/usr/bin/uic-qt4 GUI/PositionEditorWidget.ui -o GUI/ui_PositionEditorWidget.h
make[1]: /usr/bin/uic-qt4 : commande introuvable
make[1]: *** [GUI/ui_PositionEditorWidget.h] Erreur 127
make[1]: quittant le répertoire « /home/yaour/Téléchargements/zyGrib-3.8.3/src »
make: *** [zyGrib] Erreur 2
avec
QTBIN=/usr/lib/qt4/bin
j'ai le probleme suivant a la fin :
make[1]: quittant le répertoire « /home/yaour/Téléchargements/zyGrib-3.8.3/src/proj-4.6.0/src »
cd src; /usr/lib/qt4/bin/qmake; make
/bin/sh: /usr/lib/qt4/bin/qmake: not found
make[1]: entrant dans le répertoire « /home/yaour/Téléchargements/zyGrib-3.8.3/src »
/usr/bin/qmake -unix -o Makefile zyGrib.pro
make[1]: quittant le répertoire « /home/yaour/Téléchargements/zyGrib-3.8.3/src »
make[1]: entrant dans le répertoire « /home/yaour/Téléchargements/zyGrib-3.8.3/src »
/usr/bin/uic-qt4 GUI/PositionEditorWidget.ui -o GUI/ui_PositionEditorWidget.h
make[1]: /usr/bin/uic-qt4 : commande introuvable
make[1]: *** [GUI/ui_PositionEditorWidget.h] Erreur 127
make[1]: quittant le répertoire « /home/yaour/Téléchargements/zyGrib-3.8.3/src »
make: *** [zyGrib] Erreur 2

donc je pense qu'il faut
QTBIN=/usr/bin
dans le makefile
mais du coup je ne comprend pas d'ou vient le probleme

quand je regarde la version de qmake que j'ai c'est :
qmake -v
QMake version 2.01a
Using Qt version 4.5.2 in /usr/lib
donc je pense que qt4 est bien installé

donc s'il vous plait quelqu'un pourrait-il m'eclairer
merci

DomH
Site Admin
Posts: 303
Joined: 23 Jan 2009 09:03

Re: probleme pour installer zygrib sur ubuntu 9.10

Post by DomH » 21 Feb 2010 16:52

yabiti wrote:bonjour
je debute sur linux et j'avoue que je ne comprend pas mon probleme

j'ai voulu installer zygrib 3.8.3
merci
Bonjour,

Il y a deux méthodes, je m'explique:

1. la compilation est nécessaire si on charge le code source et pour cela c'est décrit ici : https://www.zygrib.org/index.php?page=do ... tion_linux

2. si vous avez ubuntu, nous avons déjà compilé le tout et c'est un paquet .deb qui s'installe selon https://www.zygrib.org/index.php?page=do ... ion_ubuntu

En résumé vous suivez la démarche suivante:

Comme vous avez la version 9.10, ajouter dans /etc/apt/sources.list
* avec la version qt4.5 (pour les versions ubuntu => 9.04):
deb http://doc.hausser.ch/debpackages ubuntu-dha free2

Clé GPG :
* Avec sudo en mode terminal :
wget http://doc.hausser.ch/debpackages/dha-debpackages.key -O - | sudo apt-key add -

puis
sudo apt-get update
sudo apt-get install zygrib

Normalement vous trouvez dans le menu accessoire zygrib avec un petit poisson comme icone

en mode terminal zygrib devrait lancer l'application.
Bonne journée ou bonne soirée (vous pouvez choisir)
Have a nice day or good night (you can choose)
Guten Morgen oder gute Nacht (Sie können wählen)

DomH

yabiti
Posts: 2
Joined: 21 Feb 2010 16:14

Re: probleme pour installer zygrib sur ubuntu 9.10

Post by yabiti » 22 Feb 2010 13:55

merci beaucoup
ça marche nikel

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 3 guests