zyGrib on the Asus eeePC

Image Ici on parle français ou anglais, comme on veut, comme on peut.
Image Here we speak french or english, as we want, as we can.

Moderator: jza

Forum rules
Image Ici on parle français ou anglais, comme on veut, comme on peut, mais on n'oublie jamais que l'on discute entre humains.
Il ne faut surtout pas oublier les mots magiques: bonjour, salut, merci, etc.
Les messages impolis sont rejetés et restent sans réponse.
Il faut souvent être patient, car il y a plein d'autres activités encore plus passionantes dans notre vie.

Image Here we speak french or english, as we want, as we can, but we never forget that we discuss between humans.
Do not forget the magic words: hello, hi, thank you, etc.
Rude messages are rejected and remain unanswered.
It is often necessary to be patient because there are many other activities even more exciting in our life.
Post Reply
Posts: 2
Joined: 07 Feb 2009 17:36

zyGrib on the Asus eeePC

Post by manxices » 07 Feb 2009 17:51

I am trying to install zyGrib to run on an Asus eeePC 900 Linux version:
Unfortunately, it seems older versions of library files provided on the Asus are unable to run the latest version of zyGrib and, having installed the debian version, the following error occurs
".. /libs/tls/libc.so.6: version 'GLIBC_2.4' not found (required by ./zyGrib) .."
The 900 is supplied with GLIBC_2.3 and it is apparently dangerous to the rest of the system to install later versions.
To try to solve the problem, I am now trying to run zyGrib using the Windows version with Wine translation software. I have uncompressed all zyGrib files to a memory stick and can run zyGrib.exe perfectly on a windows PC. However, when I try to run the program on the Linux eeePC, the program loads WITHOUT any maps or button icons.
Can anyone explain how I get these to load?
All help very gratefully received .... I really want to get this superb software to run on my little eeePC!

Added on 9 Feb 09:

To clarify my the earlier message, although the program loads without the world map or button icons being visible, it appears to work perfectly otherwise - so it is possible to download and view grib files but without the world map 'underlay' for positioning being visible.
One solutions might be for a menu option to allow one to choose folders in which to store downloads, base maps, etc, or for an .INI file to contain this information and to direct the program where to 'look' for the data.
It would be useful, perhaps, to store downloaded grib files in a folder separate from the main program directories (or on a separate drive) - data files can then be easily deleted oremptied without going near to the program files themselves.
Unfortunately, I am not competent to know if this is possible within the present program structure but perhaps someone will know of a solution?
Asus eeePC900 - linux

Posts: 1
Joined: 12 Feb 2009 20:43

Re: zyGrib on the Asus eeePC

Post by carlo » 12 Feb 2009 20:56

I also use an asus eeePC (701) and had the same problem.
My solution: I installed the asus Software Development Kit (SDK) on my desktop pc.Then the zygrib source was downloaded on my pc and then I compilled with "make". Next step: The finished binaer file I transfered to the eeec pc (USB-Stick).
Now it works fine.

Posts: 7
Joined: 02 Feb 2009 21:33

Re: zyGrib on the Asus eeePC

Post by nico » 18 Feb 2009 23:29

the problem is that the icons and maps are not found. In my case zygrib is looking for the maps in /home/username/maps/ .... so I moved all the directories in /home/username/ and this works fine.

Posts: 2
Joined: 07 Feb 2009 17:36

Re: zyGrib on the Asus eeePC

Post by manxices » 19 Feb 2009 01:09

Nico's solution works well - copying the folders (and sub-folders) '..../maps' , '..../img' and '..../tr' to the root directory under '/My Home' (ie. the same directory as /home/user) solved the problem of seeing button icons and position maps on my Asus eeepc 900 (linux) running under 'Wine'.

Downloaded grib files are saved into the ..../grib directory in '/home/user/.wine/drive_c/Program Files/zyGrib/grib' and can be accessed from the zyGrib program menus, etc.

The only problem remaining is that text labels on the map screen are not legible. Points of Interest (POI's) can be read by changing the POI font under >Options to, say, Small Screen Fonts but I don't know how to select fonts for screen text (such as Country names or time stamps on downloaded gribs where the text is just compressed into a small symbol.) Any ideas, I wonder?

Thanks to nico and carlo for their help so far, though - wonderful ......
Asus eeePC900 - linux

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest