Météotable ne fonctionne plus avec la V4.0

Image Ici on parle français ou anglais, comme on veut, comme on peut.
Image Here we speak french or english, as we want, as we can.

Moderator: jza

Forum rules
Image Ici on parle français ou anglais, comme on veut, comme on peut, mais on n'oublie jamais que l'on discute entre humains.
Il ne faut surtout pas oublier les mots magiques: bonjour, salut, merci, etc.
Les messages impolis sont rejetés et restent sans réponse.
Il faut souvent être patient, car il y a plein d'autres activités encore plus passionantes dans notre vie.

Image Here we speak french or english, as we want, as we can, but we never forget that we discuss between humans.
Do not forget the magic words: hello, hi, thank you, etc.
Rude messages are rejected and remain unanswered.
It is often necessary to be patient because there are many other activities even more exciting in our life.
Post Reply
Damien41
Posts: 20
Joined: 26 Oct 2010 05:06

Météotable ne fonctionne plus avec la V4.0

Post by Damien41 » 15 May 2011 13:16

Bonjour et tout d'abord bravo pour la nouvelle version qui apporte de très belles nouveautés.
Cependant, j'ai un petit soucis lorsque je veux lancer un météoatable. Je clics sur la carte bouton droit -> météotable et la une fenêtre s'affiche avec "zyGrib a cessé de fonctionner" avec la touche fermer le programme. Impossible de faire fonctionner cette fonction avec la nouvelle version. J'ai retourné le problème dans tous les sens, j'ai refait une installation... rien à faire j'ai toujours le même problème.
Pourriez-vous m'aiguiller ? merci d'avance.

jza
Site Admin
Posts: 600
Joined: 19 Jan 2009 00:22

Re: Météotable ne fonctionne plus avec la V4.0

Post by jza » 15 May 2011 18:51

Bonjour,
Ça ne résout rien, mais vous êtes le seul à signaler un tel problème.
Je viens de faire une nouvelle série de tests, sous linux, windows (xp) et mac, et je n'ai rien remarqué.
Vu la forte utilisation des météotables pour beaucoup d'utilisateurs, moi le premier, je pense que cela aurait déjà été signalé à de nombreuses reprises.

Peut-être pas assez de mémoire ? Mais si c'est ça il y aurait sûrement d'autres plantages à d'autres moment.
A priori, le plus lourd en consommation de mémoire, c'est de lancer une animation. Ça passe, ça ?

Si quelqu'un a une idée...
A+
Jacques

Damien41
Posts: 20
Joined: 26 Oct 2010 05:06

Re: Météotable ne fonctionne plus avec la V4.0

Post by Damien41 » 15 May 2011 19:47

Bonsoir,

En effet je ne comprends pas pourquoi systématiquement ce plantage quand je lance le meteotable alors que sur les anciennes versions je n'ai jamais eu de problèmes.
La création des animations fonctionnent très bien ainsi que toutes les autres fonctions du logiciel.
Mon PC est très récent avec windows 7 et je n'ai aucun problème de mémoire.

Je viens de réessayer en installant l'ancienne version et cela fonctionne.

J'ai remis la version 4 et toujours le plantage.

Si quelqu'un peut trouver une solution je suis preneur.

Merci d'avance.

jza
Site Admin
Posts: 600
Joined: 19 Jan 2009 00:22

Re: Météotable ne fonctionne plus avec la V4.0

Post by jza » 15 May 2011 23:19

Re,
A tout hasard et sans grande conviction, essayez une réinitialisation complète du programme.
Avant de le lancement :
  • 1. Supprimer complètement l'entrée zyGrib de la base de registres (dans HKEY_CURRENT_USER/Software) avec la commande regedit.
    2. Effacer le fichier data/config/zygrib.ini (il sera recréé avec les valeurs par défaut)
    3. S'il existe, effacer complètement le dossier C:\Documents and Settings\VousMême\zygrib
A+
Jacques

Damien41
Posts: 20
Joined: 26 Oct 2010 05:06

Re: Météotable ne fonctionne plus avec la V4.0

Post by Damien41 » 16 May 2011 22:09

Re,

++++++++1
BRAVO
cela fonctionne très bien.
Par contre lorsque je sélectionne tous les paramètres dans Options de meteotable là cela replante mais bon c'est pas grave je fais en plusieurs extractions avec moins de données.

Encore merci.

jza
Site Admin
Posts: 600
Joined: 19 Jan 2009 00:22

Re: Météotable ne fonctionne plus avec la V4.0

Post by jza » 19 May 2011 13:27

Re,
Damien41 wrote:Par contre lorsque je sélectionne tous les paramètres dans Options de meteotable là cela replante
Je crois avoir trouvé l'origine du problème (bug lors de l'allocation de couleur si une valeur est en dehors de la plage "normale", ce qui peut arriver avec certaines données en altitude).
J'essaie de corriger ça dès que possible...
A+
Jacques

jza
Site Admin
Posts: 600
Joined: 19 Jan 2009 00:22

Re: Météotable ne fonctionne plus avec la V4.0

Post by jza » 21 May 2011 20:13

C'est corrigé avec la version 4.0.1... enfin j'espère ;)
A+
Jacques

Damien41
Posts: 20
Joined: 26 Oct 2010 05:06

Re: Météotable ne fonctionne plus avec la V4.0

Post by Damien41 » 31 May 2011 21:58

Bonsoir,

Avec la nouvelle version tout marche parfaitement bien.
Merci pour tout ce que vous faites.

Bonne continuation.

Maliki
Posts: 4
Joined: 05 Aug 2010 10:17

Re: Météotable ne fonctionne plus avec la V4.0

Post by Maliki » 02 Jun 2011 08:50

Bonjour,

J'ai expérimenté le même problème avec la V4.0 sous Ubuntu.

J'ai donc installé la version 4.0.1 du 21 mai 2011 et malheureusement, la météotable continue à faire planter zygrib.

Merci de tout ce que vous pourrez faire, l'outil est merveilleux.

DomH
Site Admin
Posts: 303
Joined: 23 Jan 2009 09:03

Re: Météotable ne fonctionne plus avec la V4.0

Post by DomH » 02 Jun 2011 15:31

Maliki wrote:Bonjour,

J'ai expérimenté le même problème avec la V4.0 sous Ubuntu.

J'ai donc installé la version 4.0.1 du 21 mai 2011 et malheureusement, la météotable continue à faire planter zygrib.

Merci de tout ce que vous pourrez faire, l'outil est merveilleux.
Hello

puis-je vous demander la version de ubuntu utilisée.
Bonne journée ou bonne soirée (vous pouvez choisir)
Have a nice day or good night (you can choose)
Guten Morgen oder gute Nacht (Sie können wählen)

DomH

Maliki
Posts: 4
Joined: 05 Aug 2010 10:17

Re: Météotable ne fonctionne plus avec la V4.0

Post by Maliki » 03 Jun 2011 13:28

Bonjour,

Il s'agit de la version Ubuntu 10.04 LTS. Désolé de ne pas l'avoir précisé.

Zeelui
Posts: 1
Joined: 04 Jul 2011 00:46

Re: Météotable ne fonctionne plus avec la V4.0

Post by Zeelui » 04 Jul 2011 00:58

Hi,

I have the same problem, using zyGrib 5.0 on Xubuntu 10.04. When I choose meteotable, the program simply shuts down, without further comment. The problem was present with the former 4.01 version of zygrib as well, which I had installed two weeks ago.
With zygrib 4.? on Windows XP there are no problems.

I use the meteo table quite frequently. If this cannot be solved I would like to return to 3.9. I already tried to reinstall that version, but I didn't manage to compile the old version, nor did I find the compiled deb.package online.

Thank you, Dominique, for the good work and for a program that I use a lot to assess my sailing weather.

Regards
Bjoern

DomH
Site Admin
Posts: 303
Joined: 23 Jan 2009 09:03

Re: Météotable ne fonctionne plus avec la V4.0

Post by DomH » 04 Jul 2011 04:36

Zeelui wrote:Hi,

I have the same problem, using zyGrib 5.0 on Xubuntu 10.04. When I choose meteotable, the program simply shuts down, without further comment. The problem was present with the former 4.01 version of zygrib as well, which I had installed two weeks ago.
With zygrib 4.? on Windows XP there are no problems.

I use the meteo table quite frequently. If this cannot be solved I would like to return to 3.9. I already tried to reinstall that version, but I didn't manage to compile the old version, nor did I find the compiled deb.package online.

Thank you, Dominique, for the good work and for a program that I use a lot to assess my sailing weather.

Regards
Bjoern
Hello,

Version 3.9 is no more in the repository. I'll put it back as soon as possible as it really seems that with qt4.6 it is not possible any more to compile properly zyGrib and as it is not very easy to add qt4.7 on 10.04 LTS

Jacques is the one doing the programme, I am just doing the .deb packages
Bonne journée ou bonne soirée (vous pouvez choisir)
Have a nice day or good night (you can choose)
Guten Morgen oder gute Nacht (Sie können wählen)

DomH

User avatar
sucredepasteque
Posts: 3
Joined: 06 Jul 2011 12:29
Contact:

Re: Météotable ne fonctionne plus avec la V4.0

Post by sucredepasteque » 06 Jul 2011 12:55

Bonjour,

J'ai le même souci avec la version 5.0 sous debian testing:

DBG ColorScale.cpp: 90: readFile(): Error: (colors.size() < 2) : 0
/usr/local/bin/zyGrib: line 4: 11593 Erreur de segmentation ./bin/zyGrib

Merci pour zyGrib.

jza
Site Admin
Posts: 600
Joined: 19 Jan 2009 00:22

Re: Météotable ne fonctionne plus avec la V4.0

Post by jza » 14 Jul 2011 10:19

Bonjour
sucredepasteque wrote:DBG ColorScale.cpp: 90: readFile(): Error: (colors.size() < 2) : 0
/usr/local/bin/zyGrib: line 4: 11593 Erreur de segmentation ./bin/zyGrib
Cette erreur provient probablement d'une confusion d'installation entre différentes versions.
Faites le ménage, en particulier si vous avez installé la très vieille version de zygrib encore proposée par debian, helas :(

Les paquets .deb 5.0 compilés par Dominique fonctionnent parfaitement.
A+
Jacques

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests