lookup-error zygrib-5.0.6

Image Ici on parle français ou anglais, comme on veut, comme on peut.
Image Here we speak french or english, as we want, as we can.

Moderator: jza

Forum rules
Image Ici on parle français ou anglais, comme on veut, comme on peut, mais on n'oublie jamais que l'on discute entre humains.
Il ne faut surtout pas oublier les mots magiques: bonjour, salut, merci, etc.
Les messages impolis sont rejetés et restent sans réponse.
Il faut souvent être patient, car il y a plein d'autres activités encore plus passionantes dans notre vie.

Image Here we speak french or english, as we want, as we can, but we never forget that we discuss between humans.
Do not forget the magic words: hello, hi, thank you, etc.
Rude messages are rejected and remain unanswered.
It is often necessary to be patient because there are many other activities even more exciting in our life.
Post Reply
Georges Cercel
Posts: 40
Joined: 10 Dec 2009 16:42

lookup-error zygrib-5.0.6

Post by Georges Cercel » 16 Sep 2011 07:50

bonjour à tous
J'ai bien trouvé dans le forum une réponse provisoire pour Ununtu 9-10. Je l'ai suivie, sans succès.
Puis, j'ai désinstallé puis réinstallé à l'aide d'aptitude...
J'ai, à chaque fois cette erreur qui reviens..
./bin/zyGrib: symbol lookup error: ./bin/zyGrib: undefined symbol _ZN9QListDatalldetache_growEPii
Cet avis est survenu ce matin, tout se déroulait très bien alors..

L'origine de cet avis vient-il de zyGrib ou d'UBUNTU-Lucid (10.04 LTS)

Une suggestion pour retrouver le fonctionnement habituel .

Merci.

Georges.

DomH
Site Admin
Posts: 303
Joined: 23 Jan 2009 09:03

Re: lookup-error zygrib-5.0.6

Post by DomH » 16 Sep 2011 07:58

Georges Cercel wrote:bonjour à tous
J'ai bien trouvé dans le forum une réponse provisoire pour Ununtu 9-10. Je l'ai suivie, sans succès.
Puis, j'ai désinstallé puis réinstallé à l'aide d'aptitude...
J'ai, à chaque fois cette erreur qui reviens..
./bin/zyGrib: symbol lookup error: ./bin/zyGrib: undefined symbol _ZN9QListDatalldetache_growEPii
Cet avis est survenu ce matin, tout se déroulait très bien alors..

L'origine de cet avis vient-il de zyGrib ou d'UBUNTU-Lucid (10.04 LTS)

Une suggestion pour retrouver le fonctionnement habituel .

Merci.

Georges.
Hello,
Il faut complètement désinstaller zyGrib et réinstaller, il y a eu un changement de structure de zyGrib et la version zyGrib pour 9.10 n'est plus mise à jour depuis longtemps.

PS. Il y a des réponses plus détaillées sur le forum
Bonne journée ou bonne soirée (vous pouvez choisir)
Have a nice day or good night (you can choose)
Guten Morgen oder gute Nacht (Sie können wählen)

DomH

Georges Cercel
Posts: 40
Joined: 10 Dec 2009 16:42

Re: lookup-error zygrib-5.0.6

Post by Georges Cercel » 17 Sep 2011 13:37

bonjour,
j'ai désisntallé zyGrib jusqu'au plus profond (!) du système.. Ne restent que les fichiers grib.bz2 dans /home.
La réinstallation par synaptic s'est effectuée sans erreurs manifestes.
Le fichier desktop n'est pas revenu, lancé en console, je retouve la même erreur lookup.

Que faire ???

Merci d'une future réponse/conseil.

Georges

Georges Cercel
Posts: 40
Joined: 10 Dec 2009 16:42

Re: lookup-error zygrib-5.0.6

Post by Georges Cercel » 17 Sep 2011 15:36

Re... et voila...voila...
Je viens de mettre à jour LinuxMint(10-04, j'ai oublié le nom de version) installé sur mon ordinateur portable.
zygrib_5.0.6- a remplacé la version précédente fonctionnant sans souci(s) jusqu'à maintenant.

Lors du lancement dans la console, j'ai eu la même erreur affichée undefined symbol: _ZN9ListDatalldetach_growEPii
et, en plus, un avis GTK-Message: failed to retrieve property 'GtkTreeView:: odd-row-color ' of type 'GtkColor' from rc file value
"((Gstring*) 0x844b570)"

Mint est plus verbeux que Lucid, mais je ne suis guère plus avancé.

A votre sagacité..

Georges

Georges Cercel
Posts: 40
Joined: 10 Dec 2009 16:42

Re: lookup-error zygrib-5.0.6

Post by Georges Cercel » 19 Sep 2011 10:23

bonjour,
environnement UBUNTU-Lucid -10.04 LTS

Pour pouvoir récupérer les fichiers grib, j'ai finalement intallé le paquet trouvé dans
http://packages.ubuntu.com/fr/lucid/zygrib.
en utilisant Gdebi.
C'est la version 3.5.0-3, et elle répond sans lookup-error.

Je ne retenterais pas une mise à jour, patience..

du même jour, un peu plus tard:
rien ne va.. version ci-dessus indiquée, obsolète et ne charge pas les fichiers à partir du serveur.
snif!! :oops: :(

Georges

Georges Cercel
Posts: 40
Joined: 10 Dec 2009 16:42

Re: lookup-error zygrib-5.0.6

Post by Georges Cercel » 21 Sep 2011 14:17

bonjour,
toujours le même sujet.
Je viens de réinstaller Lucid de A à z . Puis j'ai suivi la procédure pour installer zygrib;
Je lance en console, et me trouve devant le même avertissement du lookup error...
Ce m'est pas Lucid qui est en cause, je le pensais (à 50%) car j'avais d'autres bugs ..

Wait and see, il reste la version windows qui me permet de surveiller les typhons et autre météores.

Amicalement.

NB: je viens de me rendre compte que j'ai confondu l et 1 -ma vue baisse -
J'en profite pour rappeler le message:
./zyGrib: symbol lookup error: ./zyGrib: undefined symbol: -ZNQLisrData11detach_growEPii

Georges

jza
Site Admin
Posts: 599
Joined: 19 Jan 2009 00:22

Re: lookup-error zygrib-5.0.6

Post by jza » 21 Sep 2011 20:22

Bonjour,
En effet, il y a un problème.
En attendant une mise à jour du paquet, vous pouvez compiler zyGrib en partant des sources, c'est pas si compliqué et ça prend 10 minutes :
  • 1. Depuis le gestionnaire de paquets, installer ces 3 paquets ubuntu et leurs dépendances :
    • 1. libqt4-dev
      2. g++
      3. libqwt5-qt4-dev
    2. Télécharger les sources Linux et les décompresser (en principe ça se fait tout seul, y'a qu'à dire ok)

    3. Ouvrir un terminal, puis :
    • 1. Aller (cd) dans le répertoire des sources
      2. taper : make
      3. patienter un peu...
      4. quand la compilation est terminée, copier le programme à la place de celui qui ne marche pas :
      sudo cp src/zyGrib /opt/zyGrib/bin/
    5. Cliquer la jolie icone de zyGrib dans le menu Applications/Education

    6. C'est tout, arroser ça ;)
A+
Jacques

DomH
Site Admin
Posts: 303
Joined: 23 Jan 2009 09:03

Re: lookup-error zygrib-5.0.6

Post by DomH » 21 Sep 2011 22:22

Georges Cercel wrote:bonjour,
toujours le même sujet.
Je viens de réinstaller Lucid de A à z . Puis j'ai suivi la procédure pour installer zygrib;
Je lance en console, et me trouve devant le même avertissement du lookup error...
Ce m'est pas Lucid qui est en cause, je le pensais (à 50%) car j'avais d'autres bugs ..

Wait and see, il reste la version windows qui me permet de surveiller les typhons et autre météores.

Amicalement.

NB: je viens de me rendre compte que j'ai confondu l et 1 -ma vue baisse -
J'en profite pour rappeler le message:
./zyGrib: symbol lookup error: ./zyGrib: undefined symbol: -ZNQLisrData11detach_growEPii

Georges
Hello,
J'ai refait le paquet, c'est OK maintenant
Bonne journée ou bonne soirée (vous pouvez choisir)
Have a nice day or good night (you can choose)
Guten Morgen oder gute Nacht (Sie können wählen)

DomH

Georges Cercel
Posts: 40
Joined: 10 Dec 2009 16:42

Re: lookup-error zygrib-5.0.6

Post by Georges Cercel » 22 Sep 2011 07:38

bonjour,
un grand MERCI (et plus!!) pour vos réponses ..
Je vais suivre le petit tuto à petits pas pour la compilation ..
Si
tout se passe bien ...
alors
ce sera une des rares fois. n'anticipons pas..
sinon
retour au paquet rempaqueté.

Amicalemnt

Georges

Georges Cercel
Posts: 40
Joined: 10 Dec 2009 16:42

Re: lookup-error zygrib-5.0.6

Post by Georges Cercel » 22 Sep 2011 13:42

Bonjour,
j'ai suivi les consignes de jza pour la compilation.
tout s'est bien passé: affichage; connexion au serveur (il fera beau demain !!!)
Lancé en console, lorsque j'y suis revenu, j'ai eu ce message de DBG:

DBG ColorScale.cpp: 91 readFile():Error: file data/colors/colors_deltatemp_celcius.txt: color.size() <2: 0

Faut-il apporter une modification dans le ficher source ??

Merci à jza pour ses conseils.
Plus tard, je passerais au paquet rempaqueté par DomH. Avant je change Mint pour la dernière
Debian stable.. sur le portable
A chacun sa "galère"

Merci à vous

Georges

Georges Cercel
Posts: 40
Joined: 10 Dec 2009 16:42

Re: lookup-error zygrib-5.0.6

Post by Georges Cercel » 27 Sep 2011 13:57

Bonjour à toutes et tous
Depuis me dernier message j'ai été un peu débordé.
Je viens de gratter jusqu'au fond d'apt. et réinstaller (merci synaptic) le dernier paquet
revu par DomH.
Tout baigne...
Grand merci pour ces réponses
et un punch à tout le monde.

Georges

Résolu, et garder les conseils de jza pour la compilation.

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 2 guests